Symptom
You receive the following error while performing Solution level check from the SDK.
Error - 'The underlying connection was closed. A connection that was expected to be kept alive was closed by the server.'
Environment
SAP Cloud Applications Studio
SAP Cloud for Customer
SAP Business ByDesign
Reproducing the Issue
-
Login to SDK.
- Open PDI Solution.
- Right click on the Solution in Solution Explorer.
- Click on Check 'Items' or 'Items and Runtime Objects'
- You will receive error message after sometime.
Cause
This error message appears when the solution is huge and server timeout happens.
Resolution
To perform the Check for huge Solution it is recommended to perform 'Enable Background Mode' and then do Solution Check.
-
Login to SDK.
- Open Solution.
- Right click on the Solution in Solution Explorer.
- Click on Check > Enable Background Mode.
- You can perform the solution level check now.
- To find the logs of the check you can click on 'Display Logs'.
See Also
Keywords
Server Time out, SDK, Check , KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , AP-RC-BDS-1O , ByDesign Studio OneOffs , Problem
Product
Attachments
KBA Capture.PNG |