Symptom
When sending an email output for a billing document, a message "No email recipient has been maintained" is issued.
When checking details of the output item, the "To" email address is not filled:
Environment
- Sales and Distribution (SD)
- Output Management
- SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open app "Create sales order" to create a sales order.
- Go to menu "More" -> "Extras" -> "Output" -> "Header" -> "Edit".
- Check the output item with channel EMAIL.
Cause
Check the settings accordingly.
Resolution
Firstly go to app "Output parameter determination". In the determination step "Email Recipient". See if any recipient email address is maintained here. This has highest priority.
Secondly if DEFAULT email address is maintained in the first step, the system will read the recipent email from the relevant business partner.
If the recipient is a customer, go to app "Maintain business partner". Make sure an email is maintained on tab "Address".
If the recipient is a contact person, go to app "Maintain business partner". Search with customer number. Then click the button "Relationships". Find the contact person. Make sure the valid to date is 12/31/9999. Click the change button. Click on "Assign Company Address" under "Address Data", the email address needs to be filled here.
See Also
Set-up instructions in scope item 1LQ
Fiori APP Maintain Business Partner
Fiori APP Output Parameter Determination
Keywords
S4, HANA, BP, contact person, customer, address, ADR6, relationships, business partner, AP, email address, CL_BILLING_OUTPUT_CONTROL, GET_DATA_FOR_ROLE, 1LQ , KBA , SD-BIL-GF-OC , Output Control Billing , SD-BF-OC , Output Determination , SD-BIL-GF-OC-2CL , Output Control Billing (Public Cloud) , CA-GTF-OC , SAP S/4HANA output management , Problem