Symptom
How to match OptionID between two instances?
Environment
- SAP SuccessFactors HCM Suite
- Metadata Framework (MDF)
Reproducing the Issue
- When exporting a picklist from source instance and importing this picklist to the target instance, the optionID value is different in the target instance.
- When performing an Instance Sync between two instances, the optionID value is different in the target instance.
- After performing an Export/Import Picklist, business rules which are associated with picklists display inconsistencies.
Cause
This is an expected behavior. While performing an Export/Import Picklist or an Instance Sync, system will use the current optionID sequence in the target instance to generate new option IDs.
This process is necessary to ensure that the option ID uniqueness will continue on the target instance and don't be overlaped with some value that might already exist.
Resolution
Only workaround available would be performing an Instance Refresh which would copy all existing data from the source to the target environment.
This workaround must be considered as the last resource in this case. The customer should be responsible for deciding whether to perform the refresh or not, as it will have a significant impact on the entire instance.
NOTE: More info about Instance Refresh see KBAs 2088117 and 2277508.
Keywords
Option ID, MDF Picklist, Picklist Center, same optionID, change OptionID, match option id, option id sequence, STE-11946 , KBA , LOD-SF-MDF-PKL , Picklists , Problem