Symptom
After making a change to an appointment, or a visit, a workflow rule gets triggered, but it fails with the error message "Action COMPLETE not possible; action is disabled".
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Activities/Visits work center.
- Go to the Appointments/Visits view.
- Open appointment/visit ABC (ABC represents the appointment/visit you want to change).
- Enter edit mode.
- Make a change on a field that is editable, for example
- Click Save.
- Go to the Workflow Changes facet.
You can see that the workflow rule is in status Failed.
Cause
The appointment/visit which you have changed was already in status Completed. There are certain fields within an appointment/visit that can be edited even after the appointment/visit was completed.
The workflow fails because the timing of the workflow rule is On Every Save. After making a change to an already completed appointment/visit, the system throws the error message "Action COMPLETE not possible; action is disabled", as it cannot set the status to Completed again.
Resolution
This behavior is expected as the status already was Completed.
Keywords
Appointment, Activity, Workflow Rule, Complete, Error, visit , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-ACT , Activities , Problem