Symptom
You try to associate a lead with an account displayed in the Duplicate Check. However, after selecting an existing account, you realize that the system has created a new Prospect and has associated this prospect to the lead.
Environment
SAP Sales Cloud
Reproducing the Issue
- Go to the Sales work centre.
- Go to the Leads view.
- Select the Unassigned query.
- Open an unassigned lead.
- Click Actions > Associate Account and Contact.
- Select an account from Duplicate Check screen.
RESULT: You can see "1 selected". - Open the account selected and check the ID.
- Click Save.
- Go back to the lead and open the account associated to the lead.
RESULT: It is a Prospect and the ID is different from the account selected in the Duplicate Check.
Cause
The option "Accept" should be clicked after selecting the account in the Duplicate Check.
This design avoids that we select a row for just viewing the details of an existing account and then associate the lead to this account by mistake.
Hence, if you do not click Accept, the system will understand that you do not want to associate the lead with the row selected and hence, will create a prospect for it.
Resolution
- Go to the Sales work centre.
- Go to the Leads view.
- Select the Unassigned query.
- Open an unassigned lead.
- Click Actions > Associate Account and Contact.
- Select an account from Duplicate Check screen.
RESULT: You can see "1 selected". - Select the tick under the Actions column.
- Click Save.
See Also
Keywords
lead, associate, account, prospect, duplicate check, , KBA , LOD-CRM-LM , Lead Management , Problem