Symptom
"No Data" message is seen in the Custom CDS Views app when previewing a CDS view
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to the Custom CDS Views app
- Select a CDS view where the Access Protection details are listed as Protected
- Click on Preview for this view
- In the preview of the data there is no real data, and the message "No Data" is displayed
Cause
If there is really data in this view, the user may not have authorization to see the data
Resolution
- As an example, while trying to view I_MaintOrderOperationData, adding a role to the user that would give access to the Display Maintenance Order app would let you preview data in this view
- If you are not sure of what role to add, an case can be created for the component responsible for that specific view
- Go to the View Browser app
- Search for the View
- This app will list the responsible component for that view
See Also
Keywords
Access Protection Protected I_ , KBA , BC-SRV-APS-GKE , Generic CDS Key User Editor , Problem
Product
SAP S/4HANA Cloud all versions