Symptom
When trying to preview a Custom CDS View but no data is being returned.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to the Custom CDS Views app.
- Select a Custom CDS View.
- Click on Preview for this view.
- In the preview of the data there is no real data, and the message "No Data" is displayed.
Cause
If there is really data in this view, the user may not have authorization to see the data.
Resolution
Add the required authorization to the user.
As an example, while trying to view I_MaintOrderOperationData, adding a role to the user that would give access to the Display Maintenance Order app.
If it's not clear what role to add, search for the primary datasource in SAP Help Portal or create an incident for the component responsible for that specific view. To find the concerned component, follow the steps below:
- Go to the View Browser app.
- Search for the View.
- This app will list the responsible component for that view.
See Also
Keywords
Access Protection, custom cds view, no data, preview, returning, null, value , KBA , BC-SRV-APS-GKE , Generic CDS Key User Editor , Problem