SAP Knowledge Base Article - Public

2769550 - Reason Code Not Available to Be Added in a Lead

Symptom

You need to add the field 'Reason Code' to the layout of leads, but it is not available.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Leads view.
  3. Click on Adapt -> Edit Master Layout.
  4. Open lead ABC (ABC represents the lead ID).
  5. While editing the layout screen, add fields.
  6. The field 'Reason Code' is not available. 

Cause

The lead ABC is not in the status 'Accepted' or 'Rejected'. Only leads with the mentioned status can have a reason code maintained. If the lead is maintained with a different status, the field will not be available for it. You can check this with the below steps:

  1. Go to the Business Configuration work center.
  2. Go to the Overview view.
  3. Open the fine tune activity 'Leads'.
  4. Click on 'Assign Reasons'.
  5. Only reasons for status 'Accepted' and 'Rejected' are maintained. 

Resolution

This is the standard system behavior.

You need to edit the layout of a lead which has the status 'Accepted' or 'Rejected' to add the field 'Reason Code' to the layout.

See Also

2630032 - Field Reason Code Not Available in the Lead. Error: "Please Enter a Reason Code"

Keywords

Lead, Reason Code, Field, Missing, Layout , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions