SAP Knowledge Base Article - Public

2769622 - Activity Is Not Added from Activity Advisor

Symptom

When you complete an activity task added from the activity advisor and try to add another one from the activity advisor, this second task is not added to the opportunity.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work centre. 
  2. Go to the Opportunities view.
  3. Open any opportunity.
  4. Go to the Sales Activities facet.
  5. Select an activity task from the Activity Advisor.
  6. Click Add.
  7. In the Activities pane, select this task.
  8. Click More -> Set As Complete.
  9. Select the same or another task from the activity advisor.
  10. Click Add.
  11. The message "Your entries have been saved" is displayed but the activity is not added to the Activities pane.

Cause

After you complete the task or another activity on the Activities pane, the Activity Advisor should be refreshed before you add another activity.

Resolution

This is the expected system behavior.

You should refresh the Activity Advisor after changing the status of activities.

After this:

  1. Click the More button in the Activity Advisor pane.
  2. Click Refresh.
  3. Select an activity from the advisor.
  4. Click Add.
  5. The activity should be added to the opportunity.

Keywords

Activity Advisor, Opportunity, Activity , KBA , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions