Symptom
You are trying to log in to the tenant in SDK and a pop up screen appears for Multi-Customer Solution Logon Mode. This mode has 2 options such as:
-
Load MCS Solution -> Installation Key
- Deploy MCS Solution.
Without selecting any of these options you will not be able to login to the tenant.
Environment
SAP Cloud for Customer
SAP Business ByDesign
SAP Cloud Application Studio
Reproducing the Issue
-
Launch Cloud Application Studio in your system.
- Provide the tenant details and credentials for Logon.
- Pop up appears.
Cause
This can happen due to below 2 reasons:
- If you have assigned the MCS work center assignment under Partner development Work Center in the User and Access Management work center view.
- If you have created a MCS solution in this tenant.
Resolution
Please find the resolution for both the above mentioned use cases:-
Case 1: You will have to unassign the MCS view from the user assignement in Application and User Management work center view in the UI.
Case 2. You will have to provide the MCS key to login to SDK. The MCS key would have generated during the first deployment of the MCS solution to this tenant.
Keywords
MCS key pop up unable to login to SDK due to MCS key Multi customer solution key required Installation key required , KBA , mcs key pop up , not possible to access sdk , cannot login to sdk due to mcs key , AP-RC-BDS-1O , ByDesign Studio OneOffs , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Problem