Symptom
In the Application Log of a Payment Run, you see several messages under the Results tab.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Payables Work Center.
- Open the Payment Run view.
- Select the Payment Run XYZ (XYZ is the payment run ID).
- Open the Application Log ABC (ABC is the application log ID) of the Run XYZ.
- Navigate to the Results Tab.
- You can see several messages.
Cause
In the Results tab of the payment run application log, you can view all the messages generated during an individual execution of a payment run.
The messages and any action required are explained in the Resolution section.
Resolution
All proposals postponed; total payment proposed exceeds account balance
It is a warning message. It means that the overall account balance (both payables and receivables) has been checked and indicates that the overall proposed payment amount is not required. This check considers all created payment proposals regardless of currency and payment details. The most common reasons for this message are:
- On account payments are not considered by the payment run (unless you specify that they should be when you create the run).These items are, however, still open and therefore visible in the balance.
- Items that are locked by a clearing process, such as when a clearing is still in approval, are not selected by the payment run. These items are, however, still open and therefore visible in the balance.
- The payment run does not consider net payables and receivables, but the balance check does consider both. Therefore, if the business partner is both customer and supplier, payment proposals may be postponed due to open items of the other account type.
Note that down payments are not considered by the balance check.
To solve the same you can:
- Ignore the balance check warning and execute the payment anyway by choosing Reset Postpone.
- Void the individual payment proposal.
- Edit the proposal to add or remove items.
Ideally, however, you should maintain accounts on a regular basis to keep the number of balance check warnings to a minimum.
All proposals postponed; exchange rate <Currency1> to<Currency2> missing
It is an error message and means that the account balance check could not be processed successfully.
To solve the same, you can:
- Maintain the exchange rate and execute the run again.
- Ignore the balance check warning and execute the payment anyway by choosing Reset Postpone.
<Payer/Payee/AccountID> blocked for payments
It is an information purpose, and means that a payment block has been set in the master data and is active on the current payment date.
Note that the system checks both customer/supplier and payer/payee for payment blocks.
No action is required on this message.
Void not possible: payment <ProposalID> locked by <UserID>
It is an error message. It means that the payment run generally voids any existing proposals for items that it selects to optimize the grouping of items for payment.
In this case, the system was not able to void a proposal because it is locked by another user.
If you want to optimize the grouping, contact the user or execute the run again later.
Proposal discarded; Payment not possible as items balance to zero
It is a warning message, and this message means that proposals for items that balance to zero are not created because no payment is necessary. These items are, however due.
In this case, you can do the following:
-
Check whether payment is required and pay manually if necessary.
- Clear the items balancing to zero manually.
Proposal discarded; Incoming payment data missing for <PayerID>
It is an information message. In general incoming payments are externally initiated. Therefore, proposals for incoming payments are not created if the payment data for initiating the payments is missing.
No action required if the payments are externally initiated.
If the payments are internally initiated, you must provide the missing payment data and execute the run again or pay manually.
Outgoing payment data missing for <PayeeID>
It is a warning message. In general outgoing payments are internally initiated. Therefore, proposals for outgoing payments are created even though the required payment data is missing.
To solve the same you must provide the missing payment data before you can execute the payment.
<ItemType> <ItemID> (open amount <Amount>)
It is an information message. The proposal has been discarded. This message shows which items would have been paid with the proposal.
No action required. You can use the information provided if you need to follow up manually.
<ItemType> <ItemID> currently locked by user <UserID>
It is an error message. This item is due, but is currently locked by another user.
If you want to pay this item, contact the user and pay the item manually or execute the run again later.
<ItemType> <ItemID> excluded; not due according to payment strategy
It is an information message. The item has been excluded from the payment proposal based on the strategy defined during business configuration.
No action required.
<ItemType> <ItemID> excluded; locked by <Payment/Clearing> <DocumentID>
It is a warning message. It means that item has been excluded from the payment proposal because it is already included in a clearing process or payment process.
To solve the same you can either complete the process that is locking the item or discard it manually. Either way, you should check that the item is fully cleared, because an additional payment may be required for a remaining open amount.
<ItemType> <ItemID> excluded; error converting currency <Currency1> to <Currency2>
It is an error message, and is being displayed because the item has been excluded from the payment proposal because its currency could not be converted.
To solve the same, you need to maintain the exchange rate and execute the run again.
<ItemType> <ItemID> excluded; defined payment method is externally initiated
It is an information message. The item has been excluded from the payment proposal because the payment method defined individually for the item is externally initiated. Such as check payment on a customer invoice.
No action is required in this case.
<ItemType> <ItemID> blocked for payments
It is an information message, and means that a payment block has been set for this item and is active on the current payment date.
No action is required.
Down payment <ItemID> excluded
It is an information message, because down payments are excluded by payment runs, because they are only interim items that are followed eventually by invoices.
They are also excluded by the account balance check.
No action required.
Payment contains items of <Customer/Supplier ID>
It is an information message and means that a payment proposal covers at least one item belonging to an account other than the payer/payee's account. It occurs when a payer also makes payments on behalf of other accounts, for example.
No action required.
Proposal postponed; on account payment with foreign currency
You have chosen to include on account payments in the payment run. At least one on account payment is in a currency other than the currency of the corresponding account. The payment proposal is postponed.
You need to check the proposal in the payment proposal list.
Payment not possible; incoming payment data missing for <Customer ID>
It is an information message. The payment proposal has not been generated because no internally initiated payment method is maintained. Only externally initiated payments are possible for.
No action is required.
See Also
Help Document: Messages in the Payment Run Application Log
Keywords
Payment Run, Application Log, Error messages, Warning message, Information; Zahlungslauf; Zahlungen , KBA , SRD-FIN-ACP , Payables , Problem