SAP Knowledge Base Article - Public

2770442 - Value help suggestion or auto suggest does not work on Mobile App

Symptom

No value help suggestions are shown when you type a value for an OVS field on C4C Extended Application on Mobile.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Logon to the C4C Extended App on a Mobile Device.
  2. Navigate to a screen such as a Visit Quick create screen.
  3. Tap on an OVS field, such as the Account OVS field.
  4. Type a few alphabets in the OVS field.
  5. You do not get any dropdown showing type ahead.

Cause

The company setting 'Enable Value Help Suggestion in Phone' is not enabled in your tenant.

Resolution

To enable the feature:

  1. Logon with a key user.
  2. Click the User Icon (on the top right).
  3. Settings.
  4. Company Settings.
  5. Enable the setting 'Enable Value Help Suggestion in Phone'.

See Also

Define Company Settings

Keywords

Type ahead, OVS field, Value help Search suggestion App, Suggested, Extended app, Mobile, Smartphone, Application, Android, iOS, iPhone, iPad, , KBA , AP-RC-MOB-UIF , Responsive UI , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions