SAP Knowledge Base Article - Public

2771143 - The Product List Sequence is Altered In Survey

Symptom

You have created a Product list in the Product list work center view. However, when this Product List is added to a Survey, the Product sequence is different.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Visits work center.
  2. Open the Visit ABC (ABC represents the Visit ID).
  3. Select Actions.
  4. Start Perfect Store Execution.
  5. Open the Survey DEF (DEF represents the Survey ID).
  6. The sequence of the Products in the Product list differ from the sequence in the product list work center view.

Cause

The system does not consider sequence number maintained in product list for product list determination. This is as per design.
Please note that products can be derived from more than one product list. In such a scenario sequencing cannot be maintained as there is no priority assigned at a product list level. Also the same products may be available in multiple product list, in such cases it is also not possible to assign the correct sequence to a product.

In the case, when the Product List is valid, the product valuations are saved in the correct sequence. However, if the same Product List becomes invalid and the visit is refreshed, only the products that are no longer valid in the current valid Product List will be deleted. No other valuations will be updated in the database. Sorting of valuations on refresh is not supported as it may negatively impact performance.

 

Resolution

This is the expected system behaviour.

As a workaround, because refresh occurs only for surveys with OPEN status, it is recommended to delete the survey and re-add it.

Keywords

Products, List , Sequence, Survey , KBA , LOD-CRM-PRO , Products , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions