Symptom
You receive the following error message when using the Check Connection function in the Communication Arrangement:
- Error accessing service; Service Ping ERROR: Unauthorized (401)
Environment
-
SAP Cloud for Customer
- SAP Business ByDesign
Reproducing the Issue
-
Log into the Cloud Solution.
- Go to the Administrator work center.
- Go to the Communication Arrangement view.
- Open the affected communication arrangement.
- Go to the Technical Settings facet and click on Edit Advanced Settings.
- Select your service.
- Click the Check Connection button.
You will now receive the error:
Error accessing service; Service Ping ERROR: Unauthorized (401) followed by Ping Failed.
Cause
The cause of this issue is that the user that the Service is authenticated with is currently locked.
Resolution
To resolve this issue, you must unlock the user maintained in the Communication Arrangement setup. You can do this by opening the Technical Users in the Administrator work center and using the action Unlock. You can finally set a new password for the Communication Arrangement.
The error will then disappear and the service will work again.
Keywords
Web, Service, Ping, Error, 401 , KBA , LOD-C4C-NET , Network Connectivity and Certificates , Problem