SAP Knowledge Base Article - Public

2772043 - KUT Fields Deleted After External Pricing in C4C

Symptom

You have created Extension field(s) (KUT) for Sales Quote/Order. After requesting External Pricing, the values of the KUT field(s) are deleted.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Request external price from a C4C Sales Quote/Order
  2. After receiving the pricing information from External System(ERP/S4), the KUT fields values are erased.

Cause

The extension field (KUT) field is only supposed to be sent as part of the request to ERP/S4. As this field is not populated in the response from external system after requesting the pricing, the current field data is deleted.

Resolution

Remove the KUT field(s) as part of Response Structure for the used service interface (CustomerQuoteRequestExternalSalesDocumentDataOut) in Adapt Mode.

Keywords

KUT Fields C4C external pricing , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins 1902 ; SAP Cloud for Customer add-ins 1905