Symptom
When you open a Survey in a logon language ABC (ABC stands for a logon language, for example Dutch or French), the Survey name field only shows the ID and the questions are shown in the language XYZ. You do not wish for the questions to be translated into the language ABC, only the name of the Survey.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: a Survey 123 that has questions in German and in English for example.
-
Logon in a language other than German or English (for example Dutch or French).
- Go to the Surveys workcenter.
- Go to the Surveys view.
- Find the Survey 123 and note that only the ID is being displayed, not the name.
- Go to the Design facet and note that the questions are being shown in German or English.
Cause
The Survey 123 has no translation in the logon language ABC, hence only the ID is displayed instead of the name. In the Survey facet, the fall back value is the ID when no description is added for the Survey in the logon language. This is an expected behavior and inline with other master data documents. For example, the Products workcenter also shows only the ID when the description is not maintained in the logon language. Only for transaction documents (e.g visits) the description is not language specific and we always show the same description everywhere.
The questions are being displayed in the original language XYZ in which the Survey was created when the logon language ABC is not maintained. In this case this is the fallback language which is being used.
Resolution
-
Logon in the language XYZ.
- Go to the Surveys workcenter.
- Open the Survey 123.
- Add the new language ABC and maintain the name.
- Do not click Update Languages! Clicking it will add the new language to the questions and you will have to add the translations.
- Close the dialog box using the X on the top right corner and save the survey.
See Also
Keywords
survey, id, translation, logon language, questions , KBA , LOD-LE-SUR-DEF , Survey definition = design time , Problem