Symptom
When a manager tries to approve Leave or Time Sheet directly without going into the workflow details page, they see a blank error message: "error"
If the Manager selects the individual workflow to go to workflow details UI, they can approve it successfully.
Environment
Employee Central, Workflow
Reproducing the Issue
- Proxy as a manager
- Try to approve request for time off / timesheet for any employee from Mass approval UI> blank error intermittently appears
- Select individual workflow from list to go to Workflow Request UI > you can approve /decline / update the same workflow with no error
Cause
This type of issue can sometimes happen due to o'data not being properly refreshed.
Resolution
In such cases it is suggested to go to Admin Center > OData API Metadata Refresh And Export > refresh the odata.
Keywords
ECT-115497, blank error approving workflow, empty error approving workflow, Couldn't find generic object instance of type: HRISLOGGERCONFIG , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , LOD-SF-EC-TIM , Time Off , LOD-SF-EC-TMS , Time Sheet , Problem