Symptom
You are trying to upload attachments to sales order with the web service "CustomerOrderProcessingManageCustomerOrderIn", but you're receiving the error message "Update not possible; specified data for CUSTOMER_ORDER-ATTACHMENT_FOLDER does not exist" in the response payload.
Environment
SAP Cloud for Customer
Cause
In the payload ActionCode 06 has been used in the payload's tag "<AttachmentFolder DocumentListCompleteTransmissionIndicator="false" ActionCode="06">".
The error appears as the action code 06 stands for no change.
Resolution
Since the ActionCode 06 stands for no change, you should use the ActionCode 01 to create attachment documents.
You should use the ActionCode 01 as follows in the below payload's tag.
<AttachmentFolder DocumentListCompleteTransmissionIndicator="false" ActionCode="01">.
OBS: Before triggering the payload please check if the attachment node is already created or its a fresh entry.
This can be verified using the web service "CustomerOrderProcessingQueryCustomerOrderIn".
As the attachment is already available, the action code "01" will give the message as "Instance with the same key".
ActionCode = 01 : For first attachment (Along with the attachment file, the node instance is getting created).
ActionCode = 06: If you are adding further attachment file.
See Also
Keywords
CustomerOrderProcessingManageCustomerOrderIn, Attachment , KBA , LOD-SC-DEF , ByD Fall-back / DO NOT USE , How To