Symptom
You receive an error while merging transaction records during data cleansing:
Merge Completed – Realignment Failed
Environment
SAP Cloud for Customers
Reproducing the Issue
- Go to Data Cleansing work center
- Go To Customer Merge view
- Open Merge ID: XXX (where XXX represents Merge ID)
- Go to Result Log
- Open the Application Log that has an error
- Click on Result
- Realignment failed for Activity YYY (where YYY represents Activity), Business Partner replace failed, Replace of parties failed for document ZZZ (where ZZZ represents document)
Cause
The reason for this error is that the system is not scoped to enabled enhanced document realignment during account merge.
Resolution
- Go to the Business Configuration work center
- Click on Implementation Projects
- Click on First Implementation
- Click on Edit Project Scope
- Go to the Questions tab
- Click on General Business Data
- Click on Business Partner
- Select Handling of Business Partner
- Select Do you want to enable enhanced document realignment during account merge?
See Also
2406697 - Error: "Replace of parties is rejected because determined automatically" in Data Cleansing
2345096 - Frequently Asked Questions on Data Cleansing
Customer Merge - Rules for Transaction Reassignment during Merge
Keywords
Account merge function, Merging account problem, corporate accounts, individual customers, contacts, merge duplicate records, realignment failed for activity, business partner replace failed, replace of parties failed for document , KBA , LOD-LE-BP-MRG , Business Partner Merge , Problem