SAP Knowledge Base Article - Public

2773544 - Item does not appear during library search of the title

Symptom

When searching in the library for the title of an item with any locale, it doesn't appear. However, when using the Item ID, it does.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Search in the library using an Item ID >
  2. It appears in the results.

OR:

  1. Search the same course using the Item Title (in any locale) >
  2. It does not appear in the results.

Cause

This is due to bad database index.

Resolution

Open a case with SAP Technical Support providing the Item ID and Item Title being used in the search as an Operations request will need to be utilized for database reindex if not a localization issue.

Note: For the scenario in which the item in the Legacy Search appears in a random page, not on the first result of the page, using item ID or title, the Enhanced Search available with the new Learning Home page with 2505 release does not use indexing so this scenario is unlikely to occur once the new experience is adopted.

See Also

Keywords

lms, learning, sf, successfactors, library, item, id, title, search, result, missing, not, listed , KBA , LOD-SF-LMS-CAT , Catalog , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ITE , Items , Problem

Product

SAP SuccessFactors Learning all versions