SAP Knowledge Base Article - Public

2774220 - When creating Visits from an Opportunity, the Main Contact is being added to the Attendees facet

Symptom

You create a Visit from an Opportunity, and the Main Contact is being added to the Attendees facet.

When you create a Visit directly from the Account, the Main Contact of the Account is not being added to the Attendees.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales workcenter.
  2. Go to the Opportunities view.
  3. Open any Opportunity that has a main contact maintained.
  4. Go to the Sales Activities facet.
  5. Add a Visit and open it.
  6. Go to the Attendees facet and note that the main contact has been added.
  7. Go to the Customers workcenter.
  8. Go to the Accounts view.
  9. Open any Account that has a main contact maintained.
  10. Go to the Visits facet.
  11. Add a Visit and open it.
  12. Go to the Attendees facet and note that the main contact has not been added. It has been added to the Contacts facet however.

Cause

The Attendee in the Visit created from an Opportunity is taken from the Opportunity; creating Visits from an Account does not automatically pull the Attendee from the Main Contact.

Resolution

This is the standard behavior for visits created from opportunities.

If attendees are added, you can manually remove them after their creation.

This can be done in the outlook add and resynced to C4C, or in C4C.

See Also

 3138352 - Visit Invites Are Automatically Sent - How To Stop Automatic Determination of Attendees

Keywords

opportunity, visit, main contact, primary contact, account , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions