SAP Knowledge Base Article - Public

2774250 - Delay After Editing the Question "Would you like to access the products even though the sales area is blocked?"

Symptom

After enabling or disabling the scoping question "Would you like to access the products even though the sales area is blocked?" in the Business Configuration work center, the new settings take effect with a huge delay. This happens sometimes, but not always. You are wondering about the reason for this system behavior.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Business Configuration work center
  2. Show Implementation Projects view
  3. Select your Implementation Project
  4. Select Edit Project Scope
  5. Go to Step 4 - Questions
  6. Expand General Business Data
  7. Go to element Products and expand Materials
  8. Add or remove "Would you like to access the products even though the sales area is blocked?" to/from Scope
  9. Finish and save the Scoping
  10. Sometimes this change needs more than an hour before being effective

Cause

This Business option allows you to control the data access to a product also based on blocked sales data in product master. Without this business option, products with blocked sales data can be accessed by all users. Selecting this business option enables the usage of sales area-based access restriction rules for the product master regardless of whether or not the products sales data is blocked.

Resolution

When you change this scoping question, a data migration job is scheduled in the backend. This job runs hourly and the job runtime depends on the data volume to be migrated. It therefore may take up to 59 minutes until the job starts. In case a huge amount of products is involved, the job itself may need about 30 additional minutes.

Thus, in the worst case you need to wait about 90 minutes, and in best cases it takes less than 10 minutes, before the changes are reflected in the system.

Keywords

changing, change, scope, checking, unchecking, delay, time lag, effective, mark, take effect , KBA , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions