Symptom
The Save button for a Business Role with ID "0"is grayed out, and you cannot edit the Business Role changes.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to the Application and User Management Work Center.
-
Go to Business Roles View.
-
Edit the Business Role with ID "0".
-
The Save button is grayed out, even after you make changes to the Business Role
Cause
This issue occurs because the Business Role ID is "0" and the script is treating number "0" as initial. This is a limitation in the current script.
Resolution
Create a new role with a different ID by copying the business role and then use the new business role wherever it is required.
Keywords
Business Role; ID; 0; save; button; grayed out; grayed out; , KBA , business role , id 0 , save button , SRD-CC-IAM , Identity & Access Management , Problem
Product
SAP Business ByDesign all versions