Symptom
- You are uploading emails with attachments via Outlook Add-In and you get the error "Upload of MIME type application/octet-stream not permitted".
- The attachments have all a permitted format as per your settings.
Environment
SAP Cloud for Customer
Reproducing the Issue
- When an e-mail is uploaded from the Outlook Add-In that contains specific attachment formats which are accepted by Cloud for Customer, the error is shown.
- Affected file formats can be MS Office Documents (docx, xlsx, pps), Images (jpg, png, bmp) and others.
Cause
- Some e-mail servers will set the MIME type of non-text attachments to Application/Octet-stream.
- The MIME is an internet standard that extends the e-mail format to support non-text attachments and other features.
- As the Application/Octet-Stream MIME type is not accepted by default in Cloud for Customer, it is possible that several different attachment formats will be blocked depending on the configuration of the e-mail.
Resolution
Change the allowed MIME types for attachments in Cloud for Customer via a Business Configuration Activity:
- Go to the Business Configuration Work Center.
- Select Overview and click Go to populate the Activities.
- Select Allowed MIME Types activity.
- Click Change Immediately.
- Set the MIME type Application/Octet-Stream (MIME Type Code 10024) as Allowed.
Keywords
email upload, outlook add-in , KBA , e-mail , LOD-CRM-SC-EML , Email , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions