Symptom
When you convert a Lead to an Opportunity, the fields "Account" and "Primary Contact" cannot be edited from the QuickCreate window of the new Opportunity.
Environment
SAP CLOUD FOR CUSTOMER
Reproducing the Issue
Pre-requisite: You create a Lead with an existing Account and Contact.
- Go to the Sales workcenter.
- Go to the Leads view.
- Open ABC (ABC represents the Lead with existing Account you want to convert to an Opportunity).
- Actions.
- Convert to Opportunity.
Results: In the QuickCreate window, the Account and Primary Contact Fields are grayed out
Cause
Conversions demand consistency throughout the document flow, hence the Customer masterdata cannot be changed when converting a Lead to an Opportunity
Resolution
This is the system design.
Keywords
Lead Conversion, Convert Lead to Opportunity, Lead with existing Account and Contact, Field grayed out, Account, Primary Contact. , KBA , LOD-CRM-LM , Lead Management , LOD-CRM-OPP , Opportunity Management , Problem