SAP Knowledge Base Article - Public

2774758 - Account and Primary Contact fields are Grayed out in the QuickCreate of the Opportunity Generated by Lead Conversion

Symptom

When you convert a Lead to an Opportunity, the fields "Account" and "Primary Contact" cannot be edited from the QuickCreate window of the new Opportunity.

Environment

SAP CLOUD FOR CUSTOMER

Reproducing the Issue

Pre-requisite: You create a Lead with an existing Account and Contact.

  1. Go to the Sales workcenter.
  2. Go to the Leads view.
  3. Open ABC (ABC represents the Lead with existing Account you want to convert to an Opportunity).
  4. Actions.
  5. Convert to Opportunity.

Results: In the QuickCreate window, the Account and Primary Contact Fields are grayed out

Cause

Conversions demand consistency throughout the document flow, hence the Customer masterdata cannot be changed when converting a Lead to an Opportunity

Resolution

This is the system design.

Keywords

Lead Conversion, Convert Lead to Opportunity, Lead with existing Account and Contact, Field grayed out, Account, Primary Contact. , KBA , LOD-CRM-LM , Lead Management , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions