Symptom
You are running customer account statement where the data is spanning two fiscal years and there is no content in the output data.
In South Africa, it is a legal requirement for companies to send regular account statements to their customers in order to receive due payments.
For each customer, the statement is generated as a PDF file and shows a summary of the opening and due amounts and balance for each included business document, such as customer invoices or credit memos.
The generated statement also shows the amounts overdue by timeframes of 30, 60, 90, and more than 120 days.
You can configure your output settings so that each generated statement is automatically e-mailed to the customer.
Country: South Africa
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to Receivables work center.
- Go to Customer Account Statement view.
- Select the Run ID XYZ (XYZ represents Run ID)and click open the View Report Run Results.
- Go to the tab Data Prepared for Export which is empty.
However, there are documents which the Run XYZ should have picked and this can be checked from the below path.
- Copy the Customer ID and go to Receivables workcenter.
- Go to the Customer account and open the copied Customer Id.
- Go to Trade Receivables tab and then Postings tab.
- Here add the Posting Date From/To as per the selection criteria in the customer account statement Run XYZ and click Go.
You see there are documents which are across two fiscal year.
Ideally, the opening balance should have been 0.
The Debit amount=sum of invoices & Credit amount=sum of payments
Cause
Currently, this is the system behavior when the documents are spanning across two different fiscal years.
Resolution
As a work around, you need to create two different runs for two different fiscal year.
This way each run will pick the documents for that fiscal year.
Keywords
Customer Account Statement, South Africa , KBA , south africa , customer account statement , SRD-FIN-GLO-REP , GLO - Statutory Reporting , Problem