Symptom
The user is searching Account ID with leading zeros on basic search, however no records are found.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Customer work center.
- Go to the Accounts work view.
- Search the Account ID 123 (123 defines the Account ID) on basic search with leading zeros, for example 00123.
Result: The message "records not found" is displayed.
Cause
The basic search has not considered leading zeros once it can cause performance issue.
Resolution
In case the user tries to search an account with leading zeros the advanced search has to be used.
Keywords
Account, Basic Search, Leading Zeros. , KBA , LOD-CRM-ACC , Account , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions