SAP Knowledge Base Article - Public

2775429 - Address information not coming through from Recruiting Management to Employee Central - Manage Pending Hires

Symptom

In Manage Pending Hires some portlet information is not coming through for Recruiting Management, even tho the fields are properly mapped.

Environment

SAP SuccessFactors

  • Recruiting Management
  • Employee Central
    • Manage Pending Hires

Reproducing the Issue

  1. Find the candidate in Manage Pending Hires;
  2. Click in Hire the candidate;
  3. Find the Address Portlet with information missing;

Cause

This is caused by the system having different types of address.

Resolution

Check the type of address that is present on the mapping from RCM to EC. We will use Home as an example:

<mapping-attribute>
   <source refid="address" entity-type="application"/>
   <target refid="homeAddress.address.home"/>
</mapping-attribute>

The above mapping indicates that you are mapping for the Home Address. Now, when you go to Manage Pending Hires, make sure that HOME is selected in the Address Type.

OBS: If by any chance you can't find the type of address in the Address Type field, check if the option is Active in the Picklist. The system will not be able to populate the information in that case.

Keywords

Manage, Pending, Hires, Mapping, Attribute, Address, Home, Application, RCM, EC, Recruiting, Employee, Central, Not, Missing , KBA , LOD-SF-EC-INT , Manage Pending Hires (Integration RCM/ ONB/ OBX + UI) , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors Recruiting all versions