SAP Knowledge Base Article - Public

2775965 - Error Messages While Activating Purchase Order Integration using SOAP/IDoc

Symptom

You are trying to activate the purchase order integration using SOAP/IDoc but get the following error messages:

  1. "Outbound deployment failed."
  2. "Sender partner number missing."
  3. "Error while reactivating communication arrangement."

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the work center Application and User Management.
  2. Go to the view Input and Output Management.
  3. Select Communication Arrangements.
  4. Open Purchase Order Integration using SOAP/IDoc and click View All.
  5. Choose Save and Reactivate.

Now system throws error messages as described above.

Cause

The customer ID on supplier side is missing for your company.

Resolution

  1. Choose relevant business partner ID.
  2. Choose View All in the new window.
  3. Go to the tab Purchasing.
  4. Add the customer ID for the supplier.
  5. Save.

Now Save and Reactivate, the error messages does not appear, and the communication arrangement is being activated.

Keywords

IDOC; purchase order; SOAP; integration; communication; arrangement; sender partner number; outbound deployment;Outbound deployment failed, Sender partner number missing, Error while reactivating communication arrangement. , KBA , communication arrangement , outbound deployment , SRD-SRM-PRO , Purchase Requests and Orders , Problem

Product

SAP Business ByDesign all versions