Symptom
The image below belongs to an SAP Demo instance - Any resemblance to a live customer data is purely coincidental.
A customer has configured a Benefit and enabled the option for the employee to opt-out that will trigger a workflow however
on the "To do" list of the approver the Opt-out Request appears to be as Benefit Enrollment. This causes confusion as the "To do" list request is similar to the "To do" that is being generated when an employee enrolls for a Benefit.
( To know more information on how to configure opt-out and how to trigger a workflow when an employee opts out please view the following link)
Associate the Workflow with an Enrollment and Opt Out Configuration
Environment
SuccessFactors Employee Central Global Benefits 1902
Reproducing the Issue
1. Trigger an Opt out workflow to an existing Benefit of the employee by clicking the opt out button to the benefit assigned to the employee.
2. Go as 1 of the approver and check the generated "To do" request for Opt Out.
Cause
This is an expected behavior. Currently our developers are working on an enhancement through internal engineering ticket BEN-3718.
Resolution
As a customer please create an enhancement request in our community portal through this link:
2090262 - Submit an Enhancement Request via the Customer Community - Platform - Although there is already an internal engineering ticket for this enhancement it will be best
if a customer submits or vote for an existing enhancement request so that our product management will know that this enhancement is essential.
See Also
Keywords
Opt Out, Workflow, Benefit Enrollment , KBA , LOD-SF-EC-GBF , Global Benefits , Problem