SAP Knowledge Base Article - Public

2776329 - Workflow Rule Based On A Multivalued List Field Does Not Work

Symptom

You are using a Multivalued List field in your workflow rule, but the rule is not working as expected.

Environment

SAP Cloud for Customer

Reproducing the Issue

You have created a Multivalued List ABC (ABC represents the field name) field with values 111, 121 and 131 (numbers represent the field values).

The field is used in a workflow rule and the conditions created look as follows.

ABC Equal To 111

OR

ABC Equal To 121

OR

ABC Equal To 131

The expectation is, that the workflow rule gets triggered whenever a value gets added to an already existing one or when more than 1 value gets added.

Cause

Lets say the initial value of field ABC is 111. Now you add 121. The value in the backend is now maintained as 111, 121. If there is no condition ABC Equal to 111 AND 121 the workflow rule gets not triggered.

Resolution

You have to create a condition for every possible value combination.

For example:

ABC Equal To 111

OR

ABC Equal To 121

OR

ABC Equal To 131

OR

ABC Equal To 111 AND Equal To 121

OR

ABC Equal To 111 AND Equal To 131

Or

and so on.

Keywords

Workflow Rule, Multivalued List Field, KUT , KBA , LOD-CRM-WKF , Workflow , SRD-CC-BTM , Business Task Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions