Symptom
During the cycle you may find while within a collaborative step you get an error while routing.
The error message would be when attempting to route from the form and through route forms.
**Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental**
Environment
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SAP SuccessFactors Variable Pay
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SAP SuccessFactors Compensation
Cause
The cause of this would be down to a change in hierarchy which affects the collaborative step.
NOTE: We do not recommend for customers to use the collaborative step and ask for either single/iterative be used.
Resolution
Compensation and Variable Pay does not support document transfer. This feature is only available now within PM/360 forms.
In the following scenario we have two steps defined.
- Step One /Single Role - Employee (Planner)
- Step Two / Collaboration - Employee (Planner) & Employee HR
- Completion
Launch a form and the first step correctly get the worksheet within their Compensation inbox.
At this stage, should there be a change in hierarchy for this employee/planner then there would be no issue routing the form forward as normal.
However, should you in this scenario forward the form to the next step which is a collaborative step and change the employee HR for example, then you will encounter the following issue while attempting to route forward/backwards.
The reason for this is down to the worksheet already being within the step while this change took place.
As we can see from the above error message, the system is looking for a form within the updated HR's inbox and therefore cannot route as this is still within the old HR's inbox.
The solution to this would be to route the worksheet backwards to the first step. However, as the changes have already taken place while on this step the error continues to appear when attempting to route backwards.
Options
In this scenario you will be limited to one of the following options.
- Revert your hierarchy changes.
- Delete and relaunch forms so the new hierarchy is obtained where all users get worksheets.
- If there is a defined due date on the collaborative step, then using modify form route map may be leveraged to route your forms.
NOTE: If the route map step does NOT have an "Exit" user defined and the form has been sent to next step by the unchnaged employee (planner in this example), then this option may not work.
The only options would be either 1 or 2.
The following is an example should you have a defined due date within the collaborative step.
- Confirm you have a date defined on the templates route map.
- Go to Admin Center> Performance Management> Modify Form Route Map.
- Here you will have the following options. In this exmaple we are routing one worksheet which has the error.
- Select Form ID and enter your worksheet document ID. This can be obtained by either accessing the worksheet(s) information icon or via route forms.
- Select the problem step which is would be the collaborative step in this scenario.
- The date defined on due date is in the past. We are therefore going to use this and select the "Automatic send on due date" option as shown below.
- Once this is selected click "Next" to finish.
- The final step would be to manually run the "Auto Route Based on Due Date" through provisioning.
- Once this has completed the form will be forwarded to the next step.
After this process the form can be routed backwards etc if required and there will be issues or errors.
Modifying the route map to include "Automatic send on due date" and running the provisioning job will ONLY affect the forms you are selecting.
For example, should we use "Form Template" from point three abovemyou have an option to "Select a group of forms".
Using this option will then allow you to select forms which are on a specific step.
Untick the steps which you do not want to touch and leave only the step which you would like to move forms from.
Click "Update Results" to get a list of your worksheets.
Click all documents should you wish to mass route forms from the problem step.
The next step after clicking on "Next" would be the same as above where you select the option "Automatic send on due date".
This process should NOT affect any data which exists on forms. However, we do ask for you to take exports of executive review as a backup.
Additional notes
- The due date must be in the past, otherwise the job will not route the forms.
- Any type of mass update will NOT correct this as the job completes however will contain an error regarding the affected forms.
Keywords
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