SAP Knowledge Base Article - Public

2776451 - Payment Information Fields Missing when Adding Second Payment Information Record

Symptom

Customer is facing an issue when adding payment information for users. After adding the first payment method, when adding a second  certain field from the first payment method are missing from the UI, such as Bank Country, Bank, IBAN.

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"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.“

Environment

Employee Central - Payment Information

Reproducing the Issue

1. Navigate to user
2. Add payment info for user (Main > Bank Transfer > IBAN)
3. Add second payment method (Cash) and save
4. See that the first payment method is altered based on the second one added, i.e certain fields from the first payment method are no longer visible in the UI

Cause

This is a defect (not specific to 1902)

Resolution

Engineering are currently invesitgating.

NOTE: This issue occurs in "View" mode only - if you edit the record again you will see that the data was correctly saved to the database. Therefore this is a display issue.

Additionally, Manage Data can be used to verify that the Payment Information data saved to the database is correct (as Manage Data is not leveraging PP3 or the Config UI).

Keywords

Payment Information, Pay Type, Payment Method, Secondary Payment Information Record, Insert new record, Cash, Expenses, Customised Pay type, Fields missing, IBAN, Account Owner, Bank, ECT-116013, ECT-115606 , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem

Product

SAP SuccessFactors Employee Central all versions