Symptom
When a user launches content, the content keeps loading in a new window and won't play.
Environment
SuccessFactors Learning Management System (LMS) - All Supported Versions
Reproducing the Issue
When a user goes to their learning plan and launches content.
The content loads the initial page but keeps looping as per screen shot.
User launches content and sees the following screenshot:
When testing in different browsers the issue is the same and continues to loop.
Cause
There is a line of code in the content that is incorrect.
Because of the application-based entitlement, query string will be added to the URL so the way you are checking for the file path will not work with entitlement.
Resolution
What you will need to do is find the following line of code within the content:
var base = location.href.replace(/[^\/\\]*$/,'')+FIVE.config.wbt.data.contentpath;
This is the incorrect, you will need to update this with the below:
var base = location.href.replace(/([^\/\\]*\?[^\n]*|[^\/\\]*)$/,'')+FIVE.config.wbt.data.contentpath;
See Also
2316953 - Troubleshooting when Course / Content is not being marked as completed in LMS
Keywords
Content Launching, Content looping,loop video , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS , Learning Management System , Problem