SAP Knowledge Base Article - Public

2776650 - Service Entry Sheets creation triggers an authorisation error

Symptom

Employee timesheet entries should post 'Service Entry Sheets' automatically in your system. Instead the background posting fails with error 'You have no authorization for this transaction with movement type 101' (M7 121)

Environment

  • SAP S/4HANA Cloud All Versions

Reproducing the Issue

  1. Open the 'Manage my timesheet'.
  2. Enter hours in a month where there is already an existing Purchase Order and save.
  3. The system automatically tries to post the Service Entry Sheet and the Goods Receipt in the background.
  4. Check in the APP 'Monitor Log for Service Entry Sheet Generation'.
  5. Error message 'You have no authorization for this transaction with movement type 101' is visible in the log. 

Cause

Missing business catalog in the user's business role.

Resolution

  • Make sure the user approving the timesheet record has the business catalog 'SAP_MM_BC_IM_GR_PROCESS_PC' assigned in their business role.  
  • Errors that happen during automatic creation of the Service Entry Sheet or the Goods Reciept can be checked and managed via the app "Monitor Log for Service Entry Sheet Generation".   
  • After the cause of this authorisation error has been corrected the APP 'Schedule Purchasing Jobs' has to be used to generate the Service Entry Sheet and Goods Receipt.
  • When the job scheduling is processed the errors for the related time recordings are deleted from the App "Monitor Log for Service Entry Sheet Generation" (and created again if any problem still exists).
  • Make sure the administrative user scheduling the job to re-process the Timesheet entries, also has the business catalog 'SAP_MM_BC_IM_GR_PROCESS_PC' assigned in their business role.

See Also

Process documentation
KBA 2686576

Keywords

F1823, J12, Manage My Timesheet, Service Entry Sheets, time recording, M7121, M_MSEG_BWA, M_MSEG_BWE,Service Entry Sheets not generated for contingent worker. , KBA , MM-FIO-SRV , Fiori UI for Services Management , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions