Symptom
You open an account and you realise that the name format in the Contacts view is 'Surname Name' but in the Account Team view, the names are displayed as 'Name Surname'.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Customers work center.
- Go to the Accounts view.
- Open an account.
- Go to the Contacts view.
RESULT: The name is displayed as 'Surname Name'. - Go to the Account Team view.
RESULT: The name is displayed as 'Name Surname'.
Cause
The system shows the sorting formatted name ('LastName, Firstname') in the Contacts and Employee OWL. The basic idea behind this was to allow a sorting according to the persons last name.
Hence, the system will also show the same format when checking the contacts facet inside an account.
However, in the Account Team facet, the system shows BusinessPartnerFormattedName. The sequence of the name fields is defined in the business configuration and are country dependent. General Business Partner activity > NameFormat > choose the format of the account team member's country).
Resolution
The Development team is aware that the visualization chosen in different UIs is not completely consistent and they will streamline this in a future development release.
See Also
Keywords
name format, surname, name, employees, contact, account, view, OWL, General Business Partner, , KBA , LOD-CRM-ACC , Account , LOD-CRM-CON , Contact , How To