Symptom
An obsolete Registered Product cannot be set to active straight away from the Registered Product TI, but can be activated from the Installed Base TI.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: Registered Product AAA (AAA represents the Registered Product ID) has been added to the Installed Base BBB (BBB represents the Installed Base ID) and has been set to obsolete.
- Go to the Installed Base work center.
- Go to the Registered Product view.
- Open obsolete Registered Product AAA.
- Click the Actions button.
- The Active option is greyed out.
- You need to first set the Registered Product to Blocked and then the Active option will available.
- Go to the Installed Base view.
- Open Installed Base BBB.
- Go to the Items facet.
- Select the Registered Product AAA and click on the Cogwheel.
- The Activate option is greyed out.
- Select Activate Items.
- The following message will be shown “Items will be activated asynchronously. Refer Item Logs for more details.”
- Registered Product has been activated.
Cause
If a single Registered Product is being selected, the Active option will not be available. If all items have been selected, then it is possible to active the items by choosing to activate all function.
Resolution
The use case behind the different behaviour is that id there are more than 100 items in an Installed Base from which over 70 are obsolete Registered Products, then the process of finding and activating each single Registered Product is not simple.
You can use the “Activate Item” in such situations.
Keywords
Registered Product, Installed Base, Activate , KBA , activate , registered product , installed base , LOD-LE-IBA , Installed Base Data Management , How To