Symptom
You want to open a sales document attachment from the Visit Timeline but no results are shown. The attachment can be accessed from the Sales Document TI without any issue.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to the Visits Workcenter.
- Go to the Visits view.
- Open any Visit.
- Open the Timeline and find a Sales Document with an Attachment.
- Click the symbol for the Attachment.
Result: The attachment cannot be found; when you go to the Sales Document, the attachment can be found and opened.
Cause
The attachments in the Timeline are bound to the access rights of the Attachments in the Library hence the Attachment view needs to be assigned to the user.
Resolution
-
Go to the Administrator workcenter.
- Go to the Business Roles (or Business User) and find the relevant Business Role (or the Business User).
- In the Workcenter and View Assignment, find the Library workcenter and expand it.
- Assign the Attachments view to the Role/ User.
Keywords
timeline, visit, attachment , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem
Product
SAP Cloud for Customer core applications all versions