SAP Knowledge Base Article - Public

2777233 - Reset User Password custom filters not respecting RBP Permissions

Symptom

I have limited the target population for an user for an specific custom field, but when accessing Reset User Password the user is able to see the custom field value for all the users, not only those who are in the target population.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Add a custom field as a custom filter in Data Model
  2. Grant user A the permission to view this data for only users B and C
  3. User A has Reset User Password permission with everyone in target population
  4. User A goes to Reset User Password and can see all the data for the custom field when filtering, not only for users B and C

Cause

The scope of the results of the filters set on Reset User Password respect the target population of the permission "Reset User Password", and not the permission to view data for those specific fields.

Resolution

Since this is an expected behavior, it will not be possible to have different target populations for Reset User Password and for specific custom fields used as filters in this tool. You will need to match both permissions and control the scope through the target population of the Reset User Password permission.

In case you can't limit the reset user password target population due to the limitation of view of data in the custom field, you can remove the custom field as filter. Steps on how to make changes in the custom filters you can see in this KBA.

See Also

2632183 - Adding fields to the custom filters section of the Data Model

Keywords

KBA , LOD-SF-PLT-RBP , Role Based Permissions , Problem

Product

SAP SuccessFactors HCM Suite all versions