Symptom
When creating a new ticket, you notice that when trying to select a service category, the field value help displays the message No Data. You confirm that there is an active Service Catalog with corresponding categories maintained in your system, and would like to understand why the service categories are not displayed.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Navigate to Services work center.
- Navigate to Tickets work center view.
- Click on New button.
- Open the value help for the Service Category field in the ticket creation screen.
- Notice that the message No Data is displayed, even though you have an active service catalog with categories maintained.
Cause
The root cause for this issue is due to the service category type being maintained incorrectly inside the catalog that was uploaded in the system.
It is important to notice to avoid any inconsistencies the Service Category Types should be one of the following:
1 Process.
2 Incident.
4 Object Part.
5 Cause.
6 Activity (Resolution).
In case a Custom Type is maintained, the categories might not be displayed during the ticket creation.
Resolution
In order to correct your Service Catalog, you can create a new version and collect the listed category types, accordingly to your specific business case. Also, it is important to update and upload the Excel file using the correct category types.
Keywords
Service Category; C4C; Cloud for Customer; Blank; Showing Blank; No Values; No Data to Display; Service Catalog; Catalog; , KBA , LOD-LE-CSM-SIC , Service Issue Category , How To