Symptom
When users try to view pending feedback requests or declined requests in CPM View Feedback Requests, the page doesn't display the requests. The page just shows "More" link.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Continuous Performance Management
Reproducing the Issue
- Go to Continuous Performance > Feedback > Request Feedback.
- Search user and Click Send.
- Go to View Feedback Requests to review the requests.
Cause
User who requested feedback has Employee Export permission but employee who received the request is not part of the permission's target population.
Resolution
In the current design, when both User Search permission and Employee Export permission are granted to the user, the Employee Export permission target population takes precedence over the "User Search" permission target population. Hence if the user has Employee Export Permission but employee who received the request is not part of the target population, the user will not be able to view the employee's data when viewing the feedback requests.
To fix this, ensure that employee is part of the target population in RBP Manage Permission Roles where the user has been granted Employee Export permission. Tip: To quickly search which role grants a specific permission for a user, you can use the option User Role Search.
Keywords
CPM view feedback requests pending request decline feedback request , KBA , csg_q , LOD-SF-CPM-FBK , Achievement Feedback, Get Feedback , Problem