Symptom
- In the Business Rules Admin page (Configure Business Rules) the field "Assigned" is empty;
- "Assigned" column for business rules is empty.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP SuccessFactors HCM Suite
- Metadata Framework (MDF)
- SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to Admin Center;
- Go to Configure Business Rules page;
- Notice that the "Assigned" field is empty for some rules:
Cause
The feature to show the assignments of the business rules does not work for the ones under "Basic" scenario. The assignment feature works for all rules based on an application-specific scenario
Resolution
As per the current system design, any rule that is created using basic template will not show this feature. This is the current syste design, and in order to show the assignments, we recommend changing the rule to an application-specific scenario.
We have developed a function inside of Check Tool to migrate your rules from basic to specific scenarios. Please check this article in SAP Help Portal: Change of Rule Scenarios
Starting H2 2023 release, we have introduced a new assignment status and icon for cases where the system can't retrieve rule assignment information.
This enhancement provides additional details explaining why no status is shown. With such information, it is much easier to find rules that are currently not assigned and by selecting the icon, the system helps in assigning the rule correctly.
See Also
Keywords
Business Rules Admin, Assigned, empty, blank, configure business rules, assigned column , KBA , LOD-SF-MDF-RUL , Custom Oject based Business Rules , LOD-SF-EC-RUL , DO NOT USE - Business Rules & Event Derivation , Problem