SAP Knowledge Base Article - Public

2778663 - Cannot Change Invoicing Unit In Sales Order

Symptom

You cannot change the Invoicing Unit in a Sales Order, that has no follow-up invoice.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Sales Orders workcenter.
  2. Select the Sales Order view.
  3. Open Sales Order ABC (ABC represents the sales order ID).
  4. Open the General tab.

You cannot change the Invoicing Unit.

Cause

  • You have a line item of type Material, which has a selected Reason for Rejection.
  • This has set the line item to Invoicing Status Finished.
  • The Invoicing Status on Sales Order header level is set to In Process.
  • Sales Orders with header level Invoicing status In Process set Invoicing Unit to read only
  • This is the expected behavior.
  • To change the Invoicing Unit, you need to uncancel the Material line items.

Resolution

  1. Open sales order ABC.
  2. Navigate to the Item tab.
  3. Select canceled line item.
  4. Remove Reason for Rejection entry.
  5. Save the Sales Order.
  6. Close and reopen the sales order.
  7. Change the Invoicing Unit.
  8. Select a Reason for Rejection for respective line items.

Keywords

Sales Order, Invoicing Unit, Invoice Status, Greyed, Grayed, Reason for Rejection, Rechnungsabteilung, Rechnungsstatus, Ausgegraut, Absagegrund, Kundenauftrag , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign 1902 ; SAP Business ByDesign 1905 ; SAP Business ByDesign 1908