SAP Knowledge Base Article - Public

2778762 - How to prevent sending email notification on workflows

Symptom

When a workflow has been triggered a notification will be sent on any change or comment. Only To Do List items must be created - no notifications must be sent.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Employee Central

Cause

Workflow notifications are enabled by default. They can't be removed or unticked in E-Mail Notification Templates Settings.

But there are several ways to achieve this requirement.

Option 1:

Enable Single Recipient Email -  This will send all notifications to one email address. Applies to all emails.

  1. Go to Admin Center
  2. Search for Manage Email Notifications (if you do not find the tool, make sure that the permission is enabled. Go to 'Admin Center' > Manage Permission Roles > Chose the Role>  Edit >Next > Search for 'Manage Email Notifications'> Select the permision and save it). 
  3. Here you will find where to configure Single Sender:

Option 2

In Admin Center > Company and Logo Settings > uncheck the box "This option allows a company-wide setting on whether users will receive Email notifications. If 'checked', all users will receive Email on all workflow related process. If not checked, each user has an option to turn notification on/off." - applies to workflow notifications only

N1.png

You can add email addresses for all users who should recieve notifications:

N2.png

Option 3

Untick the box 'Email Notification' in Change Email Notification Setting - Applies to all emails.

You can set a filter and set the notification for a group of users in one go.

N3.png

Option 4

End-users/employees can set up their notification choice if company-wide setting mentioned in the Option 2 is unchecked in Admin Center > Company System and Logo Settings.

user settings.png

user notification settings.png

See Also

  • 2087739 - Single Sender and Single Recipient | How They Work and Setting Them Up in SuccessFactors
  • 2087890 - Top Reasons Why Email Notifications Are Not Sent or Received. Basic Troubleshooting - HXM Suite
  • 2449702 - Alert/Workflow Notification is not being received by all the CC Roles

Keywords

workflow, notifications, notification, not sent, not send, unsend, prevent, workflows , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-PLT-NOT , Email Notifications , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions