SAP Knowledge Base Article - Public

2778762 - How to prevent sending email notification on workflows

Symptom

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

  • When a workflow has been triggered a notification will be sent on any change or comment.
  • Requirement: Only To Do List items must be created - no notifications must be sent.

Environment

SAP SuccessFactors Employee Central

Cause

Workflow notifications are enabled by default. They can't be removed or unticked in E-Mail Notification Templates Settings

But there are several ways to achieve this requirement.

Option 1:

Enable Single Recipient Email -  This will send all notifications to one email address. Applies to all emails

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Option 2

In Admin Center - Company and Logo Settings untick the box for workflow email notifications - applies to workflow notifications only

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You can add email addresses for all users who should recieve notifications

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Option 3

Untick the box 'Email Notification' in Change Email Notification Setting   -   Applies to all emails

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You can set a filter and set the notifiaction for a group of users in one go.

Option 4

End-users/employees can set up their notification choice if company-wide setting mentioned in the Option 2 is unchecked in Admin Center > Company System and Logo Settings.

user settings.png

user notification settings.png

Keywords

Workflow, notifications , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-PLT-NOT , Email Notifications , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions