Symptom
Portlet Information is being cut when printing to a PDF or a Printer via Internet Explorer or FireFox browser.
Environment
SAP SuccessFactors Employee Profile
Reproducing the Issue
- Navigate to "Employee Profile";
- Click on "Actions";
- Click on "Take Action" > "Print/PDF";
- On "Choose how you want to print the profile page", select one of the available options:
- Print the entire page
- Print the selected parts
- Hit the "Print" button and see that the information displayed in the file is not complete.
Cause
This is a limitation on how Internet Explorer and FireFox browsers read the page when printing/pdf employee profile content, and not a SuccessFactors' system limitation.
Resolution
Print the Portlet information via Chrome Browser. For that, please follow:
- Access the Instance using Chrome;
- Navigate to "Employee Profile";
- Click on "Actions";
- Click on "Take Action" > "Print/PDF";
- On "Choose how you want to print the profile page", select one of the available options:
- Print the entire page
- Print the selected parts
- Hit the "Print" button;
- On "Destination" select "Save as PDF";
- Hit the "Save" and see the information be properly displayed.
Keywords
Browsers, Internet Explorer, FireFox, Chrome, Print, PDF, Print Preview, Cut, Information, Portlet, Missing, Not Displaying, Blank, Print/PDF, Actions, Profile. , KBA , LOD-SF-EP-HED , People Profile Header Ribbon , LOD-SF-EP-UI , People Profile UI (PP3 UI) , How To