Symptom
When entering a new Passport Number an error is shown below when replacing the old number.
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The following fields are required and must be filled in before you continue: "Passport number does not match the number provided by new-hire previously" |
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
1. Navigate to SAP SuccessFactors HCM > Onboarding > I-9 Reverification Process.
2. Select the affected candidate's activity and attempt to complete the I-9 Reverification.
3. An error message will appear stating: "The passport number does not match the number previously provided by the new hire."
Cause
In general, this is a common situation where an employee has received a replacement passport (as previous one is now expired).
Resolution
Live Customers:
Contact Product Support to change the passport number from the backend. Please provide the following details:
- Company ID
- Data Center
- Affected Candidate
- New Passport Number
Onboarding Support team, please refer to the internal memo.
Keywords
ONB-20182, I9 - Reverification, Onboarding 1.O, Passport Number, Passport number does not match the number provided by the new hire previously. Update the new passport number. , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , Problem
SAP Knowledge Base Article - Public