SAP Knowledge Base Article - Public

2778980 - New Hires Stuck in Signature Step - Onboarding 1.0

Symptom

  • Notice few candidates are stuck in the Signature step.
  • Receiving 'Congratulations, you have completed the first step. The rest of your onboarding process will occur at Orientation. Click here to return to the New Employee Portal.' message.
  • Asynchoronous task error at Signature step.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding 1.0

Reproducing the Issue

  1. Log into ONB Application 
  2. Pick up the affected candidate in ONB tab
  3. Notice the error message when using DocuSign Signature

See example:

kba#1.png

Cause

  • Cause 1 - If DocuSign enabled: Some forms are configured to Use DocuSign when form doesn't require signature.

See example:

kba#2.png

    • Cause 1.2: This option 'Auto Follow Signature Step' is enabled in the process.
    • Cause 1.3: If this key 'SkipPrintFormsForManager = False'

  • Cause 2: The message saying the step has been completed means that the onboardee has already signed the forms, but then the onboarding activity was restarted. The system reads that the candidate has already signed the forms, hence, the message being received.

Resolution

Solution 1: DocuSign enabled AND Asynchoronous task error is completed with error.

  1. Please be aware that including a form as part of the SIGNATURE package without Signature is generally a problem, as the form will appear in DocuSign, but DocuSign can't process it/ doesn't know what to do with it.
  2. Reconfigure the form(s) by applying the following steps one by one in the generated forms: 
    1. Access SuccessFactors
    2. Go to Onboarding > Reference Files > Forms
    3. Next, go to View Assigned PDF Forms by Processes
    4. Select affected process (e.g. CustomProcess)
    5. Edit form
    6. Untick the checkbox under 'Use DocuSign'
    7. Lastly, click Update button
  3. Try processing the candidate again.

For Implementation Partner(s) and Consultant(s)

Solution 2: This option should be unticked or disabled if process do not require Signature step.

  1. Super Admin > Account > Processes 
  2. Select affected process 

Solution 3: To bypass forms that are required for manager signature this issue can be resolved by adding the option ‘SkipPrintFormsForManager’. If this option already exist in the Account option, please ensure that the value is True.

1. Navigate to SuperAdmin > Account Options > Add Options

2. Enter the following details, then select 'Update':

Name: SkipPrintFormsForManager

Group:

Process: {enter your process name}

Type: String

Value: True

Solution 4: Raise a support ticket so the support team can move the onboarding activity to 'All documents submitted' status. Provide an approval for the support team to execute the resolution.

  • Cloud Product Support:
    1. Check the affected candidate in Superadmin, and confirm that all forms requiring signature are all signed and that the DocuSign envelope has been downloaded.
    2. Then, raise an internal ticket to the Operations Team to move the onboarding activity to 'SIGNED'.

See Also

 2894892 - Superannuation standard choice form - Candidate moved to signature step when step does not exist

Keywords

Asynchronous task, DocuSign error, Signature, SF, Success Factors, OBD, ONB, candidate stuck at signature step, new hire stuck at signature step, Congratulations you have completed the first step. The rest of your onboarding process will occur at Orientation. Click here to return to the New Employee Portal., , KBA , LOD-SF-OBD-DSN , DocuSign , LOD-SF-OBD-FRM , Country Compliance Forms , Problem

Product

SAP SuccessFactors Onboarding all versions