Symptom
When creating a Service Order, you cannot update field values Incident Category and Service Category via the ManageServiceOrderIn webservice or excel file upload.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Navigate to the Service Orders workcenter.
- Open the Service Order Processing view.
- Download the Excel Template.
You cannot change the excel template to include fields Incident Category and Service Category.
Cause
-
There is currently no option to update the field values for Incident Category and Service Category via web service.
- Also no updates are possible by using the excel upload file.
- This is the expected system behavior.
Resolution
-
You can use a PDI solution to update those fields.
- PSM write enabled fields are:
- Business Object SERVICE_ORDER Node SERVICE_TERMS DT Element Path SRV_CATEGORY_KEY-ID-CONTENT.
- Business Object SERVICE_ORDER Node INCIDENT_SERVICE_ISS_CAT.
Keywords
Service Order, Service Category, Incident Category, Web Service, Excel, Serviceauftrag, Servicekategorie, Vorfallskategorie , KBA , AP-SVO-SO , Service Order , Problem
Product
SAP Business ByDesign 1902 ; SAP Business ByDesign 1905 ; SAP Business ByDesign 1908