Symptom
-
Users are facing the "Role based security" issue in a WFA report that has a scorecard or any report component with a custom member
- The report is blank for some users (e.g. admin user)
- An admin user is able to run the report successfully
Environment
SuccessFactors Workforce Analytics (ANA) - All versions
SAP SuccessFactors HCM Suite
Reproducing the Issue
Role Based Security issue in Scorecard:
- Create a WFA/Canvas report in Report Center
- Add a Scorecard table component
- Select a custom member as a measure
- Under the Columns tab add a new column
- Select Dimension for Type
- Set a static dimension e.g. Location in "North America"
- Share the report with an user who has Tree Security permission only to see data from Location in "Europe"
- When this user runs the report, he sees the "Role Based security" error message
- The same can happen if editing the scorecard, a static filter is applied under the Filters tab
Role Based Security issue in a Report Component:
- Create a WFA/Canvas report in Report Center
- Add a report component (e.g. Composite Query)
- Select a custom member as a measure of the query
- Share the report with an user who has a restriced Tree Security permission to all items e.g. Location, Supervisor and Org Unit
- When this user runs the report, he sees the "Role Based security" error message
Blank result:
- Create a WFA/Canvas report in Report Center
- Add a Scorecard table component
- Select a custom member as a measure
- Under the Columns tab add a new column
- Select Dimension for Type
- Set "Selectable Structure" as dimension
- Run the report with an Admin user and check that the result is blank
Cause
- Role Based Security issue in Scorecard: The user does not have permission in Tree Security to see the data that was set in the dimension or filter of the scorecard.
- Role Based Security issue in Report Component: The user needs at least one Top Level node permission in Tree Security (e.g. All Locations) to run WFA reports with custom members
- Blank result: The current runtime filter (e.g. All Org Unit) is not fetching any result from the custom member
Resolution
Role Based Security issue in Scorecard:
Review the Tree Security configuration of the user i.e. enable the permission to access the data that was defined in the filter (e.g. Location in "North America") or change the filter/dimension configuration of the component to use a dynamic filter e.g. Selectable Structure:
Role Based Security issue in Report Component:
Enable at least one top Level node permission in Tree Security (e.g. All Locations) for the user to run WFA reports with custom members:
Blank result:
You can either set a static filter in the component to something that you know will bring data or use the Filters panel while running the report (e.g. Report By in a specific Org Unit).
See Also
2371918 - Custom Member filter is not working or it is not available for some users
Keywords
Role based security issue WFA report scorecard component custom member calculation workforce analytics user blank scorecard tree security , KBA , LOD-SF-WFA , Workforce Analytics & Planning , How To