SAP Knowledge Base Article - Public

2779639 - Attachment missing from Notification - Onboarding 1.0

Symptom

Attachment is missing in email notification sent to employee even though it is attached in the notification, just like as configured in the screenshot below.

Capture.PNG



Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

SAP SuccessFactors Onboarding 1.0

Reproducing the Issue

When notification email is sent to recepient, there should be two PDF forms attached to the email (per the configuration of the above screenshot). However, there was only one pdf form that was attached.

Cause

The missing PDF form may be corrupted in the backend.

Resolution

For Implementation Partner(s) and Consultant(s)

Follow the steps below and review the SAP SuccessFactors Implementation Guide. In addition, avoid creating a support ticket when receiving any error due to misconfiguration and without utilizing SAP SuccessFactors Partner Delivery Community as a support channel for any configuration questions.

Note: Superadmin access is required to fullfil this.

  • Go to Superadmin find the ONB Account ID of the Customer
  • Under See also, click on Attachments and find the missing PDF Form.
  • View the PDF and you'll receive the error "Failed to view attachment". Which means the form is corrupted.
  • Ask the customer to provide the pdf form in the case, and ask for approval to reupload them in the backend.
  • Reupload the form in superadmin and save. You should be able to view the form afterwards.

Keywords

Forms, Notifications, PDF Forms, missing, attachment, attachments , KBA , LOD-SF-OBD-FRM , Country Compliance Forms , LOD-SF-OBD , Onboarding , Problem

Product

SAP SuccessFactors Onboarding