Symptom
You are trying to edit a business user by copying access rights from an existing source (another business user, a business role), but the Copy actions are greyed out.
Environment
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SAP Cloud for Customer
- SAP Business ByDesign
Reproducing the Issue
-
Go to the Business Users work center view.
- In Cloud for Customer, this is in the Administrator work center;
- In Businss ByDesign, this is in the Application and User Management work center.
- Select the relevant business user, then click Edit > Access Rigths;
- In the business user screen, click the Actions button;
- Only the Check Access Rights Consistency option is available for selection.
Cause
The reason behind this is that this business user already has a business role assigned. As stated in the documentation in the Business User screen, a business role will overwrite the user's individual access rights. Since the Copy actions (Copy from User, Copy from Business Role) will copy those access rights into a user's individual access rights, this would not be relevant for a user with a business role already assigned — as such, the actions are greyed out.
Resolution
If you still want to use this action, simply click the button Edit Without Business Roles — this will remove all business roles assigned to the user and re-enable the Copy actions.
See Also
Keywords
Copy from User, Copy from Business Role, Disabled, Business User, Edit Access Rights , KBA , copy from user , edit a business user , SRD-CC-IAM , Identity & Access Management , Problem